Version 2.25 released

release-notes

(Wyndi Avery) #22

Still having issues with freeezing. Also, I can not longer just ran through and it auto fill my previous weight/reps. That’s was a great feature, made it quick and simple.


(Michael Means) #23

Crashes Gone! BUT, every time I return from the timer it adds a set and sets the weight to 0, which clears out the previous weight lifted indicator. The text showing my previous weight lifted next to the row is also showing the wrong weight, so once it clears it out I have no way to tell what my previous weight was except opening my actual previous workout and checking it.


(flophousedk) #24

Hi Max,
Unfortunately it doesn’t help.
I had three keyboards - Danish, English and German - and all I can see is the DOT, but it’s not a button I can click.
I wonder why the didn’t avoid this problem when updating the app?!
If it ain’t broken, don’t fix it??? Is there a way to go back to the version before the update?
@maxbrandl


(Max Brandl) #25

Ok, since this keyboard thing worked for me, I guess this bug may also be connected to the general language setting on the phone.

So I just switched my whole iPhone to danish language and this gave me the dot – adding the german keyboard as second keyboard now didn‘t fix it.
However, making the german keyboard the primary keyboard, it brought back the comma.
But I guess, this won‘t be a practicable / durable solution for you, @flophousedk :confused:

Sorry, I‘m not a GymHero developer and can‘t answer your other questions.

@jannis, please come in – I think this problem may affect a lot of users, currently.


(Jannis Hermanns) #26

Hey all!

@maxbrandl thanks for for jumping in when I wasn’t around and helping debug this, much appreciated!


@cpchoi @flophousedk I have created this thread for your weight decimals issue. We’re working on it!


@nkrandom @lostinthegame Thanks for reporting, I have created this thread to track the issue.


@slayer @flatus I have created this thread to track the issue.


@wavery What do you mean you can’t run through? That should still work? :thinking: @maxbrandl it works for you, right? Freezing is that the phone is not reacting to anythingfor a couple of seconds? Is there a way to reproduce this?


You’re welcome - thanks to you folks as well for being patient with us!


(Danny Martel) #27

The stats for each muscle group are not loading! Still error there guys


(Jannis Hermanns) #28

Hey @danny-martel, woopsies sorry for that, can you please post that picture to this thread or like that thread so we can keep track that you’re affected? Thanks!


(Danny Martel) #29

Done!!@jannis


(vekkish) #30

My stats are also not loading, since the update.

I double check to make sure all sets and reps have been entered properly in each workout to avoid any conflict or errors.

I receive the following error even when doing stats for 7 days to 3 months, there is not data to that shows…only this error message:

Error: “Invalid type in JSON writ (_NSDate)”

Thanks for all your hard work with the latest update and fixes…hope you can figure out this one.


(Danny Martel) #31

Finally I found the issue, for some reason all the exercices where now to “none” on the selected muscle group.


(vekkish) #32

re: still getting error message when clicking on Statistics

I looked at my workouts and noticed that I was putting a custom exercise called “Cardio” and had it labelled as “None” under the “Muscle Group” category.

I deleted all of these “Cardio” exercises in all my workouts and made sure all of my other exercises were labelled with the appropriate muscle group.

Once I did that, I tried ‘syncing’ again.

I then tried my “Statistics” for the 7 last workouts. All exercises for the last 7 days were appropriately labelled and the dates, sets and reps were all correctly entered.

I’m still getting the error message:

Error: “Invalid type in JSON writ (_NSDate)”

Kind of frustrating and hope the app developers can determine what’s causing this error.

Otherwise, I love using GymHero


(Max Brandl) #33

Regarding @wavery’s feedback:

  1. I didn’t have a single freeze / crash of the app since the latest beta / current live app store version.

  2. Also “running through” the form fields – be it with the arrow buttons or manually – works just fine for me: the fields are filled with grey/inactive numbers (showing last reps/weight) – and as soon as the cursor “activates” a field, that field will be filled (black/active) with that value.


(Wyndi Avery) #34

Yeah I know that is what it suppose to do, but mine is still not :disappointed:


(Jannis Hermanns) #35

Hey all, thank you very much for your feedback and patience! So do we have a problem with the statistics when no muscle group is assigned to exercises? Can somebody confirm that?


(vekkish) #36

Hi Jannis,

Still having a problem with Statistics not loading.

Receive error:
Error: “Invalid type in JSON write (_NSDate)”

I verified that all exercises were assigned a specific muscle group.

All reps and sets were entered properly.

I tried to load a Statistics for a variety of different time periods and still receive the error message…really puzzling.

Using:
iPhone 6 iOS 12.1

Thanks so much for all your hard work…it’s appreciated.


(activerog) #37

so far so good, no crashes, no dramas, working very well thank you very much.

Took long enough to get this crashing problem fixed, but congratulations on a job well done.

10 out of 10


(Arturo Hinojosa) #38

For what it’s worth, stats can show up for me, but almost all of the built in exercises are no longer mapped to a muscle group, so almost no stats actually show up. Side feature request: mapping custom exercises to multiple groups.


(Max Brandl) #39

@jannis Using this version since release now, great work, crashes and freezes are definetly gone (for me).

Nevertheless, one small thing is bugging me big time:
Say, you have an exercise with more than 5 sets – which won’t fit on an iPhone 7 screen, see attached img – and all of the fields are filled with active/black digits. It‘s more or less impossible to scroll back up to the first line of the exercise, since this will immediately activate the timer – with zero »threshold« when reaching the top of the screen.
Going back from the timer to the exercise screen now, you will end up at the bottom line of the exercise (or as mentioned before: with a new, freshly created sixth line) and have to try again to go up.

Workaround is to use the back/forth buttons, but this is really annoying, imho.
(Plus, you look like one of the guys texting in the gym :rage: :wink: )