[open] Statistics show Error: “Invalid type in JSON write (_NSDate)”


(Jannis Hermanns) #1

If you are getting a message like Error: “Invalid type in JSON write (_NSDate)” when opening the statistics, can you just respond to (or like) this thread so we know which accounts are affected? We can’t currently reproduce this, but if a bunch of you raise your hand here, we’ll find it quickly :raising_hand_man:


Version 2.25 released
Version 2.25 released
(basi) #2

I get this error!


(Danny Martel) #3

I have this as well on the lastest ios update!


(rrubalcava) #4

Same issue.


(nitecrawler1979) #5

Same here. :slightly_frowning_face:


(mthorn) #6

I get the the same error message. Is a fix coming?


(ccross) #7

Still no fix for this???


(hugoboss58) #8


(Jannis Hermanns) #9

We’re working on this bug, and the next update will fix it. If you would like to test beta versions with the fix, please see this thread on how to sign up for beta versions: How do I become a beta tester?


(Jannis Hermanns) #10

Hey @here, can you all please open the app for just a second and see if the statistics work for you today? Please report back here!


(Jannis Hermanns) #11

Ping! Is this problem solved for you folks?


(Melissa Whybrew) #12

I’m having that issue


(Jannis Hermanns) #13

@melissa-whybrew interesting! First off - apologies. You can help us find the issue:

  1. How many finished workouts do you have?
  2. How many unfinished/planned workouts do you have?
  3. Are you using Gym Hero or Gym Hero Pro?

Thank you!


(mikas) #14

I have this issue. Also date is off by almost 50 years. App says my previous workout was in 1970. :grinning: